Экспорт данных из 1С в Outlook

Как из 1С управлять почтовой программой Outlook?

//создать новое сообщение из 1С в MS Outlook
Процедура Письмо_Создать()
     //приложение
     Попытка
          Оле=CreateObject("Outlook.Application");
          ЕстьОшибка=0;
     Исключение
          Предупреждение("Не удалось создать письмо в MS Outlook!");
          ЕстьОшибка=1;
     КонецПопытки;
     //адрес
     Адрес=СокрЛП(Лицо.АдресЭ);
     //письмо
     Если ЕстьОшибка=0 Тогда
          //Outlook
          Письмо=Оле.CreateItem(0);
          Письмо.Subject=Клиент.Наименование+?(Лицо.Выбран()=0,"",", "+Лицо.Наименование);
          Письмо.Body=гЛицо(Лицо);
          Если ПустаяСтрока(Адрес)=0 Тогда
               Письмо.Recipients.Add(Адрес);
          КонецЕсли;
          Если ПустаяСтрока(Путь)=0 Тогда
               Письмо.Attachments.Add(Путь);
          КонецЕсли;
          Письмо.Display();
     Иначе
          //тема
          Тема=Клиент.Наименование;
          Если Лицо.Выбран()=1 Тогда
               Тема=Тема+", "+Лицо.Наименование+"&body="+СокрЛП(Лицо.Имя);
          КонецЕсли;
          ЗапуститьПриложение("mailto:"+Адрес+"?subject="+Тема);
     КонецЕсли;
КонецПроцедуры

//создать запись в календаре событий
Процедура Календарь_Создать()
     //приложение
     Попытка
          Оле=CreateObject("Outlook.Application");
     Исключение
          Предупреждение("Не удалось создать запись в календаре событий в MS Outlook!");
          Возврат;
     КонецПопытки;
     //задача
     Задача=Оле.CreateItem(1);
     Задача.Subject="Название встречи";
     Задача.Start="01.11.2007 15:00:00";
     Задача.End="01.11.2007 16:00:00";
     Задача.Body="Описание встречи";
     Задача.Location="Место встречи";
     Задача.ReminderMinutesBeforeStart=30;
     Задача.BusyStatus=0;
     Задача.MeetingStatus=0;
     Задача.Sensitivity=2;
     Задача.Save();
КонецПроцедуры

//создать новую задачу из 1С в MS Outlook
Процедура Задача_Создать()
     //приложение
     Попытка
          Оле=CreateObject("Outlook.Application");
     Исключение
          Предупреждение("Не удалось создать задачу в MS Outlook!");
          Возврат;
     КонецПопытки;
     //задача
     Задача=Оле.CreateItem(3);
     Задача.Subject=Клиент.Наименование;
     Задача.StartDate=ДатаДок+Константа.Фирма.ПериодСобытие;
     Задача.Display();
     Если Лицо.Выбран()=1 Тогда
          Задача.Body=
          ""+Лицо.Наименование+"
          |"
+гЛицо(Лицо)+"
          |"+СокрЛП(Лицо.Должность)+"
          |моб. "
+СокрЛП(Лицо.ТелефонМ)+"
          |гор. "
+СокрЛП(Лицо.ТелефонГ);
     КонецЕсли;
КонецПроцедуры

Реклама:
Смотрите также:
Учёт комиссионной торговли в программе 1С
Порядок сортировки, установленный в базе данных, отличается от системного?
Отчёты администратора для обслуживания 1С
Скачать программы для 1С