Экспорт данных из 1С в Word

Как данные из 1С сохранить в файле Word?

Методы работы с MS Word через OLE активно использованы в конфигурации "Договоры". Для определения числового кода текстовых констант MS Word использована обработка "Константы VBA".

//поиск текста в открытом документе MS Word
Функция Текст_Найти(Оле,аТекст)
     Текст=СокрЛП(аТекст);
     //поиск
     Оле.Selection.Find.ClearFormatting();
     Оле.Selection.Find.Text=Текст;
     Оле.Selection.Find.MatchCase=0;
     Оле.Selection.Find.MatchWholeWord=0;
     Оле.Selection.Find.MatchWildcards=0;
     Оле.Selection.Find.MatchSoundsLike=0;
     Оле.Selection.Find.MatchAllWordForms=0;
     Оле.Selection.Find.Forward=1;
     Оле.Selection.Find.Wrap=wdFindContinue;
     Оле.Selection.Find.Format=0;
     Ответ=Оле.Selection.Find.Execute();
     //найден
     Если Оле.Selection.Find.Found()=0 Тогда
          Сообщить("Текст не найден: "+Текст);
          Возврат(0);
     Иначе
          Возврат(1);
     КонецЕсли;
КонецФункции

//поиск и замена текста в документе MS Word
Процедура Договор_Заменить()
     //путь
    
Если ФС.ВыбратьФайл(0,Файл,Каталог,"Открыть старый файл","Файлы MS Word|*.doc")=0 Тогда
          Возврат;
     КонецЕсли;
     //приложение
    
Оле=СоздатьОбъект("Word.Application");
     Оле.Documents.Open(Каталог+Файл,,1);
     //переход курсора в начало текста
    
Оле.Selection.HomeKey(wdStory);
     //замена Номер договора
    
Если Текст_Найти(Оле,"ДОГОВОР")=1 Тогда
          Оле.Selection.EndKey(wdLine,wdCharacter);
          Оле.Selection.TypeText("ДОГОВОР № "+гНомерДок(НомерДок));
     КонецЕсли;
     //замена Дата договора
    
Если Текст_Найти(Оле,Константа.ГодСтарый)=1 Тогда
          Оле.Selection.MoveLeft(wdWord,3);
          Оле.Selection.EndKey(wdLine,wdCharacter);
          Оле.Selection.TypeText(ДатаДоговора());
     КонецЕсли;
     //переход курсора в начало текста
    
Оле.Selection.HomeKey(wdStory);
     Оле.Visible=1;
     //предупреждение
    
Предупреждение("Создание нового договора копированием старого выполнено.");
КонецПроцедуры

Реклама:
Смотрите также:
Учёт комиссионной торговли в программе 1С
Порядок сортировки, установленный в базе данных, отличается от системного?
Отчёты администратора для обслуживания 1С
Скачать программы для 1С