Экспорт данных из 1С в XBase

Как данные из 1С сохранить файле формата DBF?

Экспорт данных из 1С в файл dBase формата DBF

//процедура записывает данные об использовании отчёта в файл dBase формата DBF
Процедура гЗаписатьСтатистикуИспользованияОтчета(ИдентификаторОтчета) Экспорт
     //путь к файлу; имя файла не должно превышать 8 знаков
     Путь=КаталогИБ()+"Stat.dbf";
     //создание нового файла
     Б=СоздатьОбъект("XBase");
     Если ФС.СуществуетФайл(Путь)=0 Тогда
          //добавление полей
          Б.ДобавитьПоле("REPORT","S",100,0);
          Б.ДобавитьПоле("USER","S",50,0);
          Б.ДобавитьПоле("DATE","D",10,0);
          Б.ДобавитьПоле("TIME","S",5,0);
          //создание файла
          Б.СоздатьФайл(Путь);
          Б.ЗакрытьФайл();
     КонецЕсли;
     //открытие файла
     Б.ОткрытьФайл(Путь);
     Если Б.Открыта()=0 Тогда
          Сообщить("Не удалось открыть файл DBF","!");
          Возврат;
     КонецЕсли;
     //добавление записи
     Б.Добавить();
     Б.Date=ТекущаяДата();
     Б.Time=ТекущееВремя();
     Б.Report=СокрЛП(ИдентификаторОтчета);
     Б.User=гПользователь.Наименование;
     Б.Записать();
     //закрытие файла
     Б.ЗакрытьФайл();
КонецПроцедуры

Реклама:
Смотрите также:
Импорт данных в 1С из XBase
Порядок сортировки, установленный в базе данных, отличается от системного?
Отчёты администратора для обслуживания 1С
Скачать программы для 1С