Импорт данных в 1С

Как в 1С получить данные из внешних хранилищ?

В практической работе приходится проводить импорт данных в "1С:Предприятие" из различных внешних приложений, обслуживающих базы данных. Встроенный язык программы "1С:Предприятие" и стандартизированные методы построения баз данных позволяют создавать универсальные обработки по импорту данных из внешних источников. Написание универсальной обработки, зачастую, - это сложный, но и достаточно увлекательный процесс. Сложным я могу назвать его потому, что на этапе разработки нужно заранее предусмотреть все возможные варианты импортирования и обработки данных. А увлекательным процесс написания универсальных обработок по импорту данных в 1С мне видится потому, что постоянно ощущаешь огромные выгоды от использования обработки в последующей работе.

Предлагаю изучить программные методы импортирования данных в программу "1С:Предприятие 7.7" из внешних источников.

Не все умеют писать универсальные обработки, и не все получают от этого удовольствие. Но практически все, работающие с программой "1С:Предприятие" сталкивались с необходимостью импорта данных из внешних источников. Поэтому, если обработку для импорта данных в "1С:Предприятие" Вы не можете или не умеете написать самостоятельно, то я могу Вам предложить универсальные внешние обработки по импорту данных в "1С:Предприятие", которые написал я самостоятельно. Их Вы найдёте в статье "Обработки для 1С". Общие программные методы работы с внешними источниками данных описаны в статье "Внешние связи" и будут полезны для программистов.

Файловая система

А ещё хочу предложить вам инструмент, который понадобится обязательно. Это умение работать с файловой системойц из программы 1С. Если вы профессионально работаете с программой 1С, то вам обязательно придётся или записывать файлы на диск или считывать файлы с диска. Тогда вам и пригодятся нижеизложенные инструменты.

//открытие файла заданного типа
Функция гФайл_Открыть(Файл,Каталог,ФлагВсе,ФлагТекст=0,ФлагКнига=0,ФлагДокумент=0,ФлагПрезентация=0,ФлагАкробат=0) Экспорт
     //меню
     Если ПустоеЗначение(Файл)=0 Тогда
          А=СоздатьОбъект("СписокЗначений");
          А.ДобавитьЗначение(0,"Открыть");
          А.ДобавитьЗначение(1,"Выбрать");
          Ответ=0;
          Если А.ВыбратьЗначение(Ответ,,,,1)=0 Тогда
               Возврат(0);
          ИначеЕсли Ответ=0 Тогда
               ЗапуститьПриложение(Каталог+Файл);
               Возврат(0);
          ИначеЕсли Ответ=1 Тогда
               ФС.УстТекКаталог(Каталог);
          КонецЕсли;
     КонецЕсли;
     //формат
     Список="";
     Если ФлагВсе=1 Тогда
          Список=Список+"|Все файлы|*.*";
     КонецЕсли;
     Если ФлагТекст=1 Тогда
          Список=Список+"|Текстовые файлы|*.txt";
     КонецЕсли;
     Если ФлагКнига=1 Тогда
          Список=Список+"|Книги MS Excel|*.xls";
     КонецЕсли;
     Если ФлагДокумент=1 Тогда
          Список=Список+"|Документы MS Word|*.doc";
     КонецЕсли;
     Если ФлагПрезентация=1 Тогда
          Список=Список+"|Презентации MS PowerPoint|*.pps";
     КонецЕсли;
     Если ФлагАкробат=1 Тогда
          Список=Список+"|Документы Adobe Acrobat|*.pdf";
     КонецЕсли;
     Список=Сред(Список,2);
     //
     Возврат ФС.ВыбратьФайл(0,Файл,Каталог,"Открыть файл",Список);
КонецФункции

//процедура определяет название файла и каталога на основании заданной адресной строки
Процедура гПуть_Получить(Путь,Файл,Каталог) Экспорт
     Текст=СтрЗаменить(Путь,"\",РазделительСтрок);
     //каталог
     Для i=1 По СтрКоличествоСтрок(Текст-1) Цикл
          Каталог=Каталог+СтрПолучитьСтроку(Текст,i)+"\";
     КонецЦикла;
     //файл
     Файл=СтрПолучитьСтроку(Текст,СтрКоличествоСтрок(Текст));
КонецПроцедуры

Реклама:
Смотрите также:
Учёт и формирование доверенностей в 1С
Извлечение административных данных из базы 1С
Связать две информационные базы 1С
Как начислить зарплату в 1С