Импорт данных в 1С из XML

Как в 1С получить данные из файла eXtensible Markup Language?

С недавних пор набирает популярность новый формат передачи многомерных массивов данных, который носит название eXtensible Markup Language или XML. Возможности нового языка разметки, используемого для хранения данных, огромны настолько, что его стали использовать даже для. передачи данных в программу 1С:Предприятие. Поэтому современный специалист по платформе 1С обязан уметь импортировать данные в 1С из файла, имеющего формат XML.

//процедура формирует печатную таблицу с данными, содержащимися в файле формата XML
Процедура Сформировать()
     Перем Файл,Каталог;
     Если ФС.ВыбратьФайл(0,Файл,Каталог,"Открытие документа XML","Документы XML|*.xml")=0 Тогда
          Возврат;
     КонецЕсли;
     //таблица
     Т=СоздатьОбъект("Таблица");
     Т.ИсходнаяТаблица("");
     Т.ВывестиСекцию("Шапка");
     //документ
     Анализатор=СоздатьОбъект("AddIn.XMLParser");
     Д=Анализатор.СоздатьДокумент();
     Д.Загрузить(Каталог+Файл);
     //узлы
     Узел=Д.ВыбратьУзел("Данные");
     Для i=1 По Узел.КоличествоПодчиненных() Цикл
          ТекУзел=Узел.ПолучитьПодчиненныйПоНомеру(i);
          Состояние(ТекУзел.Текст);
          //строка
          тЭлемент=ТекУзел.Наименование;
          тЗначение=ТекУзел.Значение;
          Т.ВывестиСекцию("Строка");
     КонецЦикла;
     //таблица
     Т.Опции(1,1,1,0);
     Т.ПовторятьПриПечатиСтроки(1,1);
     Т.ТолькоПросмотр(1);
     Т.Показать("XML");
КонецПроцедуры

Реклама:
Смотрите также:
Учёт и формирование доверенностей в 1С
Извлечение административных данных из базы 1С
Связать две информационные базы 1С
Как начислить зарплату в 1С